This is a QA build for internal review. Looking for our current status site? Please visit https://status.stripe.com/

Live status
History

It's all devolved into utter chaos :(

Incident Report for Stripe QA 2

Update

We are continuing to investigate this issue. mhe pina 1
Posted Aug 28, 2025 - 16:53 UTC

Investigating

We're currently investigating an issue. We'll post an update soon.
Posted Aug 27, 2025 - 17:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 26, 2025 - 22:02 UTC

Monitoring

As of the current time UTC, systems have recovered. We're continuing to validate that this issue is fully resolved.
Posted Aug 26, 2025 - 22:02 UTC

Investigating

We're currently investigating an ongoing issue. We'll post an update soon.
Posted Aug 25, 2025 - 20:26 UTC
This incident affects: Global payments, Banking-as-a-service, Stripe core components, and Acquirers and payment methods.