This is a QA build for internal review. Looking for our current status site? Please visit https://status.stripe.com/

Live status
History

Fraud rate increase

Incident Report for Stripe QA 2

Update

We're currently investigating an increase in fraud rates. As of 23:27 UTC, we've observed a significant fraud event involving $1,000,000 USD and impacting 10,000 requests. We're continuing to investigate and will post further updates every hour.
Posted Sep 03, 2025 - 20:48 UTC

Investigating

We're currently investigating an increase in fraud rates. As of 23:27 UTC, we've observed a significant fraud event involving $1,000,000 USD and impacting 10,000 requests. We're continuing to investigate and will post further updates every hour.
Posted Aug 19, 2025 - 02:34 UTC
This incident affects: Banking-as-a-service.