This is a QA build for internal review. Looking for our current status site? Please visit https://status.stripe.com/

Live status
History

CSM TEST | Payment orchestration routing all high-value transactions to failing processor

Incident Report for Stripe QA 2

Update

We're currently seeing payment orchestration routing all transactions over $500 to Worldpay, which is experiencing 85% decline rates. We've identified the cause and are working on a fix. [dogfooding]
Posted Sep 03, 2025 - 20:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 20:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 31, 2025 - 03:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 31, 2025 - 03:02 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 28, 2025 - 19:33 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 28, 2025 - 18:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 26, 2025 - 22:02 UTC

Identified

We're currently seeing payment orchestration routing all transactions over $500 to Worldpay, which is experiencing 85% decline rates. We've identified the cause and are working on a fix.
Posted Aug 26, 2025 - 22:01 UTC

Investigating

We're currently investigating payment orchestration routing issues where transactions over $500 are being incorrectly routed to Worldpay, which is experiencing high decline rates. As of now, this is impacting high-value transaction processing. We're continuing to investigate and will provide updates as we learn more.
Posted Aug 20, 2025 - 22:40 UTC
This incident affects: Global payments.