This is a QA build for internal review. Looking for our current status site? Please visit https://status.stripe.com/

Live status
History

My Dog is Too Adorable

Incident Report for Stripe QA 2

Identified

We're currently seeing an issue with "My Dog is Too Adorable". We've identified the cause, and are working on a fix.
Posted Sep 02, 2025 - 22:24 UTC

Update

We're currently investigating an incident related to an adorable dog. We'll post an update soon.
Posted Sep 02, 2025 - 22:23 UTC

Investigating

We're currently investigating an incident related to an adorable dog. We'll post an update soon.
Posted Sep 02, 2025 - 22:22 UTC
This incident affects: Stripe API and Global payments.