This is a QA build for internal review. Looking for our current status site? Please visit https://status.stripe.com/

Live status
History

User is jumping out the plane without parachute

Incident Report for Stripe QA 2

Identified

We're currently seeing elevated error rates and response times with the API. We've identified the cause, and are working on a fix.
Posted Aug 25, 2025 - 22:09 UTC

Investigating

We're currently investigating this test incident. We'll post an update soon. As of the current time, we are monitoring the situation and working to understand the details.
Posted Aug 21, 2025 - 21:22 UTC